Default directory, registering file type

Need help? Can't find the answers elsewhere? Ask away...

Moderators: david, OG, Galen

Post Reply
HPG
Registered member
Posts: 20
Joined: Mon Jan 16, 2006 4:47 pm
Location: Toronto, Canada

Default directory, registering file type

Post by HPG » Mon Jan 16, 2006 4:55 pm

Please forgive me if these questions have been asked countless times, but I'm new around here:
1. How does one set the default directory so that, when saving a new file, BrainStorm doesn't always default to its program folder?
2. My installation doesn't seem to have associated the *.brn file type with BrainStorm, and it doesn't appear on the file list when I try to do it manually. What am I doing wrong? I've never before encountered an application that doesn't do this as part of the installation process.

Thanks.

jack111
Insider
Posts: 42
Joined: Sun Oct 23, 2005 8:47 am
Location: Milwaukee, WI, USA
Contact:

Are you using PersonalBrain?

Post by jack111 » Mon Jan 16, 2006 7:38 pm

Even thou BrainStorms opens a default model in its program file it is simple matter to open a new file in any directory on any disk. Simply open a new model under the BrainStorm file tab and then do a save (cntrl s) and you are prompted for the file name and you can create a new folder any where on your computer. After BrainStorm is closed the next time it reopens it will go back to that last open model. In a way the last opened model becomes the default which is not to say that you can have BrainStorm models all over the place, which you can.

Regarding the file extension question, are you using PersonalBrain? Until just recently as far as I know BrainStorm was the only program using the .brn file extension. Just recently there has been discussion on this forum regarding this conflict and proposed ways to correct this new conflict with PersonalBrain.

No matter why your machine is not opening .brn files with BrainStorm it is a simple mater to reassign that file extension back to BrainStorm with the "open with" command found by right clicking on a BrainStorm .brn file in Explorer or going into the Control Panel, Folder Options, File Types and change BRN to open with BrainStorm.

HPG
Registered member
Posts: 20
Joined: Mon Jan 16, 2006 4:47 pm
Location: Toronto, Canada

Post by HPG » Mon Jan 16, 2006 9:38 pm

Thanks very much. Good suggestion about using "last file" -- I'd turned that off, but that wasn't a smart idea in retrospect.

Turns out that the registry key that set up the .brn association was defective, which was why I couldn't get the association to work. By dint of some strange manoevres I found on the Web I managed to get rid of the key, which made it possible to set up the association in the end.

jack111
Insider
Posts: 42
Joined: Sun Oct 23, 2005 8:47 am
Location: Milwaukee, WI, USA
Contact:

Hope it's working

Post by jack111 » Mon Jan 16, 2006 9:59 pm

I hope you're up and BrainStorming now. I was just thinking in the couple of years I've been using BrainStorm I've never had to do a Registry tweak to fix something and a lot of my BrainStorm work has be on pre-released Beta versions. I sorry to hear you had to go so deep.

HPG
Registered member
Posts: 20
Joined: Mon Jan 16, 2006 4:47 pm
Location: Toronto, Canada

Post by HPG » Mon Jan 16, 2006 10:06 pm

It's the story of my life :) I've never come across a registry problem like that before -- I usually try to keep well away from the awful thing. But BrainStorm is working just fine now, thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests